Problem with LoadRunner web_text_link

Hi

I was passed a LoadRunner script developed on v11 for execution on a v11.5 installation. On execution of the script in the LoadRunner VuGen or the controller it failed on web_test_link. Tracing the error back the preceding web_test_link was not execution correctly so the web_test_link was not able to find the text of the link it should be clicking.

The failing script was aborting the download:

Action.c(105): web_text_link(“UK Autoglass OM Super User”) started [MsgId: MMSG-26355]
Action.c(105): Downloading URL “http://X-X-X.com:8001/OA_HTML/RF.jsp?function_id=MAINMENUREST&security_group_id=0″ for an ActiveX object (asynchronous POST request) [MsgId: MMSG-26000]
Action.c(105): Aborting pending download of URL=”http://X-X-X.com:8001/OA_HTML/RF.jsp?function_id=MAINMENUREST&security_group_id=0” (RelFrameId=1, Internal ID=41) [MsgId: MMSG-27656]

However, for various other reasons we had to regress the LoadRunner installation back to v11 and without any change to the script it worked… Strange but true and sorry to all the googler that thinks this post will solve their similar problem 😦

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s